summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53b8f3f8d5f4..13726d23acb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,10 @@
pkgname=makedumpfile
pkgver=1.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="A tool to generate smaller dumpfiles from kdump memory dumps"
license=('GPL2')
-depends=('perl' 'elfutils')
-makedepends=('zstd' 'lzo' 'snappy')
-optdepends=('zstd: for zstd compression'
- 'lzo: for lzo compression'
- 'snappy: for snappy compression')
+depends=('perl' 'libelf' 'zstd')
arch=('i686' 'x86_64')
url="https://github.com/makedumpfile/makedumpfile"
source=("https://github.com/makedumpfile/makedumpfile/releases/download/${pkgver}/makedumpfile-${pkgver}.tar.gz")
@@ -22,7 +18,9 @@ sha256sums=('8985f8df249087ea68c6051dec6dac3ef0703fe2aa87d0266f3951f93aa8da5e')
build() {
cd $srcdir/$pkgname-$pkgver
export CFLAGS="-fcommon"
- make LINKTYPE=dynamic USEZSTD=on USELZO=on USESNAPPY=on
+ # NOTE: to enable lzo and/or snappy compressions uncomment the following
+ # options and add the corresponding packages to the depends array
+ make LINKTYPE=dynamic USEZSTD=on # USELZO=on USESNAPPY=on
}
package() {