summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 314f203f10ba..13726d23acb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,25 @@
# Contributor: Mathieu Pasquet <mathieui@mathieui.net>
# Contributor: Bernhard Walle <bernhard.walle@gmx.de>
# Contributor: Michael Eckert <michael.eckert@linuxmail.org>
+# Contributor: Guilherme G. Piccoli <gpiccoli@igalia.com>
pkgname=makedumpfile
-pkgver=1.6.7
-pkgrel=1
+pkgver=1.7.0
+pkgrel=3
pkgdesc="A tool to generate smaller dumpfiles from kdump memory dumps"
license=('GPL2')
-depends=('perl' 'elfutils')
+depends=('perl' 'libelf' 'zstd')
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/makedumpfile"
-source=("https://netcologne.dl.sourceforge.net/project/makedumpfile/makedumpfile/${pkgver}/makedumpfile-${pkgver}.tar.gz")
-sha256sums=('e702fbdf62b4cd829a76e46f3e24eb3fc7501918b85ebdcd8baef4f53d6ee2c8')
+url="https://github.com/makedumpfile/makedumpfile"
+source=("https://github.com/makedumpfile/makedumpfile/releases/download/${pkgver}/makedumpfile-${pkgver}.tar.gz")
+sha256sums=('8985f8df249087ea68c6051dec6dac3ef0703fe2aa87d0266f3951f93aa8da5e')
build() {
cd $srcdir/$pkgname-$pkgver
- make LINKTYPE=dynamic
+ export CFLAGS="-fcommon"
+ # NOTE: to enable lzo and/or snappy compressions uncomment the following
+ # options and add the corresponding packages to the depends array
+ make LINKTYPE=dynamic USEZSTD=on # USELZO=on USESNAPPY=on
}
package() {