summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 4 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4267816f9296..f4bfbb78aabc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,9 @@
# Contributor: François M. <francois5537 @ gmail.com>
## Dynamically retrieve the download url
-_manager_source=$(wget -o /dev/null http://www.manager.io/desktop/download/ -O - \
- | grep -o -P 'https://.*manager-accounting\.zip'
+_manager_source=$(wget -o /dev/null http://www.manager.io/desktop/download/ubuntu/ -O - \
+ | grep -o -P 'https://.*Manager\.deb' | tail -n1
)
-
pkgname=manager-accounting
pkgver=$(echo "${_manager_source}" \
| grep -o -P '[0-9]+\.[0-9]+\.[0-9]+'
@@ -22,27 +21,17 @@ options=('!makeflags')
source=(
"LICENSE"
"${_manager_source}"
- "https://raw.githubusercontent.com/ericsink/SQLitePCL.raw/02ae6a75ba254fe1f6bf27495545b5eac79456ac/sqlite3/sqlite3.c"
)
sha256sums=(
'bd144763506372341487683b0f28ad627e7e8923ea8ef8569541b55f4b987061'
'SKIP'
- 'SKIP'
)
prepare() {
cd "$srcdir"
- # Check checksum
- chksum=($(sed '15q;d' "${pkgname}_${pkgver}.dsc"))
- filesum=($(sha256sum "${pkgname}_${pkgver}.tar.xz"))
- if [ $chksum != $filesum ]; then
- error "Checksums not matching"
- exit
- fi
-
# Extract, patch
- tar --strip-components=1 -Jxvf "${pkgname}_${pkgver}.tar.xz"
+ tar --strip-components=1 -Jxvf "data.tar.xz"
sed -i \
's|/usr/bin/cli|/usr/bin/mono|g' \
@@ -56,26 +45,13 @@ prepare() {
's|/opt/|/usr/lib/|g' \
usr/share/applications/manager-accounting.desktop
- # Extract libe_sqlite.so by executing ManagerServer.exe
- # on port 1 to fail on purpose.
- # ref: https://forum.manager.io/t/manager-does-not-start-after-recent-update-on-ubuntu/7950/19
- #cd "$srcdir/opt/manager-accounting"
- #mono ManagerServer.exe -port 1 2>&1 > /dev/null
-}
-
-build() {
- gcc -shared -fPIC -O3 -DNDEBUG -DSQLITE_DEFAULT_FOREIGN_KEYS=1 \
- -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 \
- -DSQLITE_ENABLE_COLUMN_METADATA -DSQLITE_ENABLE_JSON1 \
- -DSQLITE_ENABLE_RTREE \
- -o libe_sqlite3.so sqlite3.c
+ rm -rf usr/share/lintian
}
package() {
install -d $pkgdir/usr/{bin,lib,share/{applications,icons}}
cp -r opt/manager-accounting $pkgdir/usr/lib/
cp -r usr/share/icons/* $pkgdir/usr/share/icons/
- cp libe_sqlite3.so "${pkgdir}/usr/lib/${pkgname}/"
ln -s /usr/lib/manager-accounting/manager-accounting $pkgdir/usr/bin/manager-accounting
install -m644 usr/share/applications/$pkgname.desktop $pkgdir/usr/share/applications/
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"