summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc8770d13285
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Author: Madotsuki <madotsuki@national.shitposting.agency>
+
+pkgname=mandelbulber2
+pkgver=2.04
+pkgrel=1
+pkgdesc="3D application designed to render 3D fractals such as the Mandelbulb, Mandelbox, BulbBox, JuliaBulb, Menger Sponge, and Iterated Function Systems. Rewritten from scratch with new Qt based interface."
+arch=('any')
+url="http://www.mandelbulber.com/"
+license=('GPL3')
+depends=('libjpeg-turbo' 'qt5-tools' 'libpng12' 'gsl' 'openmpi')
+source=('http://downloads.sourceforge.net/project/mandelbulber/Mandelbulber%20v2/source%20-%20multiplatform/mandelbulber2-2.04.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fmandelbulber%2Ffiles%2FMandelbulber%2520v2%2Fsource%2520-%2520multiplatform%2F&ts=1438647832&use_mirror=iweb')
+md5sums=('4f0d86a0f460ffa2f2a2a5a2072a977a')
+
+build()
+{
+ cd "$srcdir/$pkgname-$pkgver/makefiles"
+ qmake mandelbulber.pro
+ make PREFIX=/usr all
+}
+
+package()
+{
+ cd "$srcdir/$pkgname-$pkgver/makefiles"
+ make PREFIX=/usr install
+}