summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41182b66d587..e58ea3a97ad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: C. Dominik Bódi <dominik.bodi@dominikbodi.de>
pkgname=mandos-server
_srcname=mandos
-pkgver=1.6.9
+pkgver=1.7.0
pkgrel=1
pkgdesc="unlock LUKS encrypted drives remotely - server component"
arch=(any)
@@ -19,18 +19,26 @@ depends=(avahi
openssh)
makedepends=(docbook-xml
docbook-xsl
- pkg-config)
+ pkg-config
+ quilt)
optdepends=('fping: host uptime checking - legacy method')
backup=('etc/mandos/mandos.conf'
'etc/mandos/clients.conf'
'etc/dbus-1/system.d/mandos.conf')
install=mandos.install
-source=("http://ftp.recompile.se/pub/mandos/mandos_1.6.9.orig.tar.gz"
+source=("http://httpredir.debian.org/debian/pool/main/m/mandos/mandos_$pkgver.orig.tar.gz"
+ 'series'
'fix_makefile.patch')
-sha256sums=('bf04b7786c5c29409ca48454de25aa3e70f2bbd3428a393d3424069f89e3a40e'
- '73af9f42039d4b843f13ca3985ec5ab4809ecd092c2f229db57e36deb671b54d')
+sha256sums=('37f145c575d4b49eaa2d0b6ed8067d1e4687f7fa3927b6154f7a5d7907ba947a'
+ 'd5d2d190799efdc4ecba1221a405983a3e770b085f055c1c156199436836dc47'
+ 'e51e3db7faa66af3bc307c7a2503b2b23d702896a5027660a01d3cc2e4dedb1b')
+
prepare() {
- patch -p2 -i fix_makefile.patch
+ mkdir "$_srcname-$pkgver/patches"
+ cp series "$_srcname-$pkgver/patches/"
+ cp fix_makefile.patch "$_srcname-$pkgver/patches/"
+ cd "$_srcname-$pkgver"
+ quilt push -a
}
build() {