summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f18f9e0d3c1e..17bf83f8dee0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,42 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
+_pkgname=MangoHud
pkgname=mangohud-git
-pkgver=0.7.1.r0.g48d8426
+pkgver=0.7.1.r20.g5598fda
pkgrel=1
pkgdesc="A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more."
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('git' 'appstream' 'cmocka' 'glslang' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako' 'vulkan-headers')
-depends=('dbus' 'fmt' 'gcc-libs' 'glew' 'hicolor-icon-theme' 'libglvnd' 'libx11' 'python-matplotlib' 'python-numpy' 'sdl2' 'spdlog' 'vulkan-icd-loader')
-optdepends=('libxnvctrl: NVIDIA GPU stats by XNVCtrl')
-provides=('mangohud')
-conflicts=('mangohud' 'mangohud-common-git')
-source=("$pkgname::git+$url")
+makedepends=('appstream' 'cmocka' 'git' 'glfw' 'glslang' 'libxnvctrl' 'libxrandr' 'meson' 'nlohmann-json' 'python-mako' 'vulkan-headers')
+depends=('dbus' 'fmt' 'gcc-libs' 'glew' 'hicolor-icon-theme' 'libglvnd' 'libx11' 'python-matplotlib' 'python-numpy' 'vulkan-icd-loader')
+optdepends=('libxnvctrl: NVIDIA GPU stats by XNVCtrl'
+ 'glfw: Required for MangoApp'
+ 'gamescope: Use MangoApp as an overlay within gamescope')
+provides=('mangohud' 'mangoapp')
+replaces=('mangoapp')
+conflicts=('mangohud' 'mangohud-common-git' 'mangoapp')
+source=("git+$url")
sha512sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd $_pkgname
git describe --tags --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- local meson_options=(
+ arch-meson "$_pkgname" build \
+ -Dmangoapp=true \
+ -Dmangohudctl=true \
+ -Dmangoapp_layer=true \
--wrap-mode=nofallback
- -Dwith_wayland=enabled
- $pkgname
- )
- arch-meson "${meson_options[@]}" build
meson compile -C build
+
}
package() {
meson install -C build --destdir "$pkgdir"
- install -Dm 0664 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 0644 "$_pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}