summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 4 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e76685257110..d30aacd2d606 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=manimce
pkgname=manim-community
_name=manim
-pkgver=0.2.0
+pkgver=0.3.0
pkgrel=1
pkgdesc="Animation engine for explanatory math videos (community edition)."
arch=('any')
@@ -10,34 +10,22 @@ url="https://github.com/ManimCommunity/manim/"
license=('MIT' 'custom')
depends=(
'python'
- 'cairo'
'ffmpeg'
- 'python'
- 'python-black'
'python-cairo'
'python-colour'
- 'python-grpcio'
- 'python-guzzle-sphinx-theme'
- 'python-matplotlib'
'python-networkx'
'python-numpy'
'python-pillow'
'python-pygments'
- 'python-pylint'
- 'python-pytest'
- 'python-recommonmark'
'python-rich'
'python-scipy'
'python-tqdm'
- 'python-watchdog'
-
# Aur dependencies
- 'python-grpcio-tools'
'python-manimpango'
'python-pydub'
)
makedepends=(
- 'sed'
+ 'python-setuptools'
)
optdepends=(
'texlive-most: latex support'
@@ -45,11 +33,10 @@ optdepends=(
conflicts=('python-manimlib')
provides=()
source=("https://github.com/ManimCommunity/$_name/releases/download/v$pkgver/$_name-$pkgver.tar.gz")
-sha256sums=('01925f8550b5dd96275259e1943a12216d18f851202aa88abde16d660148638f')
+sha256sums=('87166696E0D1D841C5721C545C55209FA4B6DCE95F0327B79EB8EF3DEBC8C11B')
prepare() {
cd "$srcdir/$_name-$pkgver"
- sed -i "/'progressbar',/d" setup.py
sed -i 's/rich>=6.0,<7.0/rich/' setup.py
}
@@ -64,3 +51,4 @@ package() {
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$_name/LICENSE"
install -D -m644 LICENSE.community "$pkgdir/usr/share/licenses/$_name/LICENSE.community"
}
+