summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d07291968596..5af1822c2b07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgver=4.0.0.g123232ffd
pkgrel=2
pkgdesc='Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)'
arch=('i686' 'x86_64')
-url='http://mapnik.org/'
+url='https://github.com/mapnik/mapnik'
license=('LGPL2.1')
depends=('boost-libs'
'cairo'
@@ -36,12 +36,16 @@ provides=('mapnik')
source=('git+https://github.com/mapnik/mapnik.git'
'mapnik-cmake-harfbuzz.patch'
'mapnik-datasource-ogr-test.patch'
+ 'mapnik-include-mapnik-geometry-cstdint.patch'
+ 'mapnik-plugins-input-csv_utils-trim_if.patch'
'git+https://github.com/mapnik/test-data.git'
'git+https://github.com/mapbox/geometry.hpp.git'
'git+https://github.com/mapbox/polylabel.git')
sha256sums=('SKIP'
'90f541c0845e3c7005564fa113771ce01cf2bcfd57662b7fa8849aabf4151638'
'3fcf178e646df526e9a5c278f56ad16e4f75d2f27108e7b33419649a46b92f52'
+ '88d8e9be1b6da2a96693a6dd4272588001d1df1ea1b34cdd9ceff081d9b79fce'
+ 'ec3034bbfc06604aefdf4c2caec7e44aff9dda65d893f2829b89f29e0d9c9c1f'
'SKIP'
'SKIP'
'SKIP')
@@ -55,6 +59,8 @@ prepare() {
cd mapnik || exit
patch -Np1 < ../mapnik-cmake-harfbuzz.patch
patch -Np1 < ../mapnik-datasource-ogr-test.patch
+ patch -Np1 < ../mapnik-include-mapnik-geometry-cstdint.patch
+ patch -Np1 < ../mapnik-plugins-input-csv_utils-trim_if.patch
git submodule init \
test/data \
deps/mapbox/geometry \