summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 281828807ce2..d2b2849957a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,26 @@
pkgname=markdown2ctags
pkgver=0.3.3
-pkgrel=2
+pkgrel=3
pkgdesc='Generate ctags-compatible tags files for Markdown documents'
arch=(any)
license=(BSD3)
url="https://github.com/jszakmeister/$pkgname"
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$pkgname-$pkgver"
source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('e633f6d9baebdfc97349707825543958aead128b6385def2a0f011ee32b0c29d')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.txt
install -Dm0644 -t "$pkgdir/usr/share/doc/$pkgname/" README.rst
}