summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 704d855dd824..5f0575646ab9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
pkgname=mastercard-pkcs11-tools
-pkgver=2.2.0
+_commit=v2.6.0
+pkgver=2.6.0
pkgrel=1
pkgdesc="Tools to manage objects on PKCS#11 cryptographic tokens"
url="https://github.com/Mastercard/pkcs11-tools"
@@ -10,7 +11,6 @@ makedepends=(
bison
flex
)
-_commit=8117c336f91b53e843f4995b691faf245c395889
source=("git+https://github.com/Mastercard/pkcs11-tools#commit=$_commit"
"git+https://git.savannah.gnu.org/git/gnulib.git"
"oasis-pkcs11::git+https://github.com/oasis-tcs/pkcs11")
@@ -31,12 +31,18 @@ prepare() {
git submodule set-url .gnulib "$srcdir/gnulib"
git submodule set-url include/oasis-pkcs11 "$srcdir/oasis-pkcs11"
+
+ git -c protocol.file.allow=always submodule update
}
build() {
cd pkcs11-tools
sh -ex ./bootstrap.sh
./configure --prefix=/usr --sysconfdir=/etc
+
+ # Hack to fix what the compiler insists is a syntax error
+ echo '#include_next <string.h>' > gl/string.h
+
make
}