summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9056673ad803..1c137c6227cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=masterpassword-cli
-pkgver=2.6
-_relver=5
-_hash=g344771db
-pkgrel=4
+pkgver=2.7
+_relver=1
+_hash=gd5959582
+pkgrel=1
pkgdesc='CLI version of Master Password'
arch=('i686' 'x86_64')
url='https://masterpassword.app/'
@@ -13,26 +13,23 @@ license=('GPL3')
depends=('ncurses' 'json-c' 'libsodium')
makedepends=('openssl')
optdepends=('xclip: copy password to clipboard')
-source=("https://masterpassword.app/mpw-${pkgver}-cli-${_relver}-0-${_hash}.tar.gz"{,.sig}
- 'fix-build.patch')
-sha256sums=('954c07b1713ecc2b30a07bead9c11e6204dd774ca67b5bdf7d2d6ad1c4eec170'
- 'SKIP'
- 'ae6cb494dba01f9941580840e7412b91973c7767cae75c935d8dd2fd2392adc3')
+source=("https://gitlab.com/MasterPassword/MasterPassword/-/raw/1e7491e0d9f39ac6d49e4078cf445ca69e71020a/mpw-${pkgver}-cli-${_relver}-0-${_hash}.tar.gz"{,.sig})
+sha256sums=('480206dfaad5d5a7d71fba235f1f3d9041e70b02a8c1d3dda8ecba1da39d3e96'
+ 'SKIP')
validpgpkeys=('5C2D1D61853F20F2FCDDCCB70EF21226F43EA6BC') # Maarten Billemont
-prepare() {
- patch -p0 -i fix-build.patch
-}
-
build() {
export LDFLAGS="$LDFLAGS -ltinfo"
+ cd cli
./build
}
check() {
+ cd cli
./mpw-cli-tests
}
package() {
+ cd cli
/usr/bin/install -Dm755 mpw "$pkgdir/usr/bin/mpw"
}