summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8be59a8cb22..bb1492c106b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,16 +24,13 @@ depends=(
)
source=("git://github.com/tootsuite/${pkgname%-git}.git#branch=$_branch")
sha256sums=('SKIP')
+install=mastodon.install
_user=mastodon
-_homedir="/var/lib/${pkgname}"
-_shell="/bin/false"
+_homedir=/var/lib/mastodon
+_shell=/bin/false
pkgver() {
cd "${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/-/_/g'
}
-post_install() {
- getent group ${_user} > /dev/null || groupadd ${_user} > /dev/null
- getent passwd ${_user} > /dev/null || useradd -d ${_homedir} -g ${_user} -s ${_shell} ${_user} > /dev/null
-}