summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4cfb72c3c06..0a945c2abfa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sergey Shatunov <me@prok.pw>
pkgname=matchbox
pkgver=0.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="Network boot and provision Container Linux clusters"
arch=("x86_64" "i686" "arm" "armv6h" "armv7h" "aarch64")
url="https://coreos.com/matchbox/docs/latest/"
@@ -9,8 +9,12 @@ license=('Apache')
makedepends=('go' 'git')
_goname=github.com/coreos/$pkgname
_commit=08f4e9908b167fba608e60169ec6a803df9db37f # 0.7.0
-source=("git+https://$_goname.git#commit=$_commit")
-md5sums=('SKIP')
+source=("git+https://$_goname.git#commit=$_commit"
+ "matchbox.sysusers"
+ "matchbox.tmpfiles")
+sha256sums=('SKIP'
+ 'b5a40ff91c6b14fcfc6261a64a1221bc2dd20403ab5727fa8c3719fe4e3a36ea'
+ 'd3fc3cd0261959e76c692a5511f7fbb0f297c62e9a2664eb0e9735cb17adc455')
pkgver() {
mkdir -p $srcdir/src/github.com/coreos
@@ -30,6 +34,7 @@ package() {
install -Dm755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
objcopy --remove-section .note.go.buildid "$pkgdir/usr/bin/$pkgname"
install -Dm644 contrib/systemd/$pkgname.service "$pkgdir/usr/lib/systemd/system/$pkgname.service"
- install -dm755 "$pkgdir/var/lib/matchbox{,/assets}"
+ install -Dm644 $srcdir/matchbox.sysusers "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ install -Dm644 $srcdir/matchbox.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
install -dm755 "$pkgdir/etc/matchbox"
}