summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37e6b8361ca0..a045dcfe3381 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-# $Id$
-# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Maintainer:
+# Contriburor: Balló György <ballogyor+arch at gmail dot com>
pkgname=mate-menu
-pkgver=5.6.9
+pkgver=18.04.3
pkgrel=1
pkgdesc="Advanced menu for MATE Panel, a fork of MintMenu"
arch=('any')
-url="https://bitbucket.org/ubuntu-mate/mate-menu"
+url="https://github.com/ubuntu-mate/mate-menu"
license=('GPL')
-depends=('mate-panel' 'python2-configobj' 'python2-gobject' 'python2-pyinotify' 'python2-xdg' 'python2-xlib' 'xdg-utils')
+depends=('mate-panel' 'python2-configobj' 'python2-gobject' 'python2-pyinotify' 'python2-xdg' 'python2-xlib' 'xdg-utils' 'python2-setproctitle')
makedepends=('python2-distutils-extra' 'python2-setuptools')
-install=$pkgname.install
-source=("$pkgname-$pkgver.tar.gz::https://bitbucket.org/ubuntu-mate/$pkgname/get/$pkgver.tar.gz")
-sha256sums=('5eb733dbd4bd12fc268e107050d703904fefb0e639defe374bd70389e951e1f2')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ubuntu-mate/mate-menu/archive/$pkgver.tar.gz")
+sha256sums=('8fe0ccbc667ca7f6cb1cd6a7d86961e755ce53e7360e6e59a45a4eeae13b1331')
prepare() {
- cd ubuntu-mate-$pkgname-*
+ cd $pkgname-$pkgver
sed -i 's@^#!.*python$@#!/usr/bin/python2@' lib/*.py
}
package() {
- cd ubuntu-mate-$pkgname-*
+ cd $pkgname-$pkgver
python2 setup.py install --root="$pkgdir" --optimize=1
}