summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7643d81ae8f4..e00c1e9efa39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
pkgname=mathics-scanner
_pkgname=Mathics_Scanner
-pkgver=1.2.0
+pkgver=1.2.3
pkgrel=1
pkgdesc="Mathics' tokeniser or scanner portion for the Wolfram Language."
arch=('any')
url="https://mathics.org/"
license=('GPL3')
-depends=('python-chardet' 'python-ujson' 'python-click')
+depends=('python-chardet' 'python-pyaml' 'python-click')
makedepends=('python-setuptools')
+optdepends=('python-ujson: faster than the native json library, but not supported in pyston')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Mathics3/$pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz")
-sha256sums=('b40c2144adb12654df600e4464cf8db6584572854476198c0d1fec3cf887f283')
+sha256sums=('b870048993020ec3a09fd6e35a2be54774f58d09fd5f6cbbb5e535041c65387a')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"