summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 22 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 985418bb77cd..0229bbb8696d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,35 @@
# Maintainer: Carlos Mogas da Silva <r3pek@r3pek.org>
+_pkgname=matrix-synapse-rest-password-provider
pkgname=matrix-synapse-rest-auth
-pkgver=0.1.1
+pkgver=v0.1.4.r25.g53fbc12
pkgrel=2
pkgdesc='REST endpoint Authentication module for synapse'
arch=('any')
-url='https://github.com/kamax-io/matrix-synapse-rest-auth'
+url='https://github.com/anishihara/matrix-synapse-rest-password-provider'
license=('AGPL3')
-depends=('python2' 'python2-twisted' 'matrix-synapse')
-source=("https://github.com/kamax-io/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('8c9368c5f1ab8e2e3a9788cf4e4ad0bcd197cc68b278efd360edb516e674658d')
+depends=('python' 'python-twisted' 'matrix-synapse')
+makedepends=('git')
+
+source=("${_pkgname}"::"git+https://github.com/anishihara/matrix-synapse-rest-password-provider.git"
+ 'Update-set_profile_displayname-to-use-UserID-type.patch')
+sha256sums=('SKIP'
+ '5fb2cfbf8ae32c7ca2d17d01f67a3492b70a7631f865c657ceb4b4ecac7d5285')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_pkgname}"
+ patch -Np1 < '../Update-set_profile_displayname-to-use-UserID-type.patch'
+}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${_pkgname}"
- PYTHON_LOCATION=$(python2 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
+ PYTHON_LOCATION=$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
# File
install -dm 755 "${pkgdir}"/${PYTHON_LOCATION}