summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2503140fc37e..70dfec7e5aba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Alex J. Malozemoff <amaloz@galois.com>
pkgname=matterhorn-bin
-pkgver=50200.4.0
+pkgver=90000.0.0
pkgrel=1
pkgdesc="A terminal-based chat client for MatterMost"
arch=('x86_64')
url="https://github.com/matterhorn-chat/matterhorn"
license=('BSD')
-provides=('matterhorn-bin')
-conflicts=('matterhorn' 'matterhorn-git')
-depends=('gmp' 'libffi' 'ncurses5-compat-libs' 'zlib')
-source=("https://github.com/matterhorn-chat/matterhorn/releases/download/${pkgver}/matterhorn-${pkgver}-ubuntu-18.04-bionic-x86_64.tar.bz2"
- "LICENSE::https://github.com/matterhorn-chat/matterhorn/raw/master/LICENSE")
-sha1sums=('3a806502c2f17ce7306abd9ec6e8e186eeca4966'
- '42e13363365a1fed1318f9e7fadd8d1760e7ba95')
+provides=('matterhorn')
+conflicts=('matterhorn')
+depends=('gmp' 'ncurses5-compat-libs' 'zlib')
+source=("https://github.com/matterhorn-chat/matterhorn/releases/download/${pkgver}/matterhorn-${pkgver}-ubuntu-22.04-jammy-$CARCH.tar.bz2"
+ "LICENSE::https://raw.githubusercontent.com/matterhorn-chat/matterhorn/master/LICENSE")
+sha1sums=('edf0e5e0a53d41ccc1ab4aa11076684a8da763a1'
+ '41bd788816973ea1340759da722bac169d6dc746')
package() {
- install -m644 -D LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- cd ${srcdir}/matterhorn-${pkgver}-ubuntu-18.04-bionic-${arch}
- install -m755 -D matterhorn ${pkgdir}/usr/bin/matterhorn
-
+ install -m644 -D LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ cd ${srcdir}/matterhorn-${pkgver}-ubuntu-22.04-jammy-${arch}
+ install -m755 -D matterhorn ${pkgdir}/usr/bin/matterhorn
}