summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a69bf3224f33..c0c8e1e2a948 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,29 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=maxima-git
-pkgver=5.47.1.111.g3f7ab0c6b
+pkgver=5.47.1.363.g0ebda7220
pkgrel=1
pkgdesc="Sophisticated computer algebra system - git-version"
arch=('i686' 'x86_64')
url="http://maxima.sourceforge.net"
license=('GPL')
depends=('sbcl' 'sh' 'shared-mime-info')
-makedepends=('git' 'perl' 'python' 'texlive-core' 'texinfo')
+makedepends=('git' 'perl' 'python' 'texlive-basic' 'texinfo')
optdepends=('gnuplot: plotting capabilities'
'rlwrap: readline support via /usr/bin/rmaxima'
'tk: graphical xmaxima interface')
provides=('maxima')
conflicts=('maxima')
options=('!makeflags' '!zipman')
-source=('maxima::git://git.code.sf.net/p/maxima/code' 'maxima.desktop' nohtml.patch)
+source=('maxima::git://git.code.sf.net/p/maxima/code' 'maxima.desktop')
sha256sums=('SKIP'
- 'd7ba38d5f35a6322b569e33a132eecf2fba36d4bc124ba75caa8e57f81753c20'
- 'd1a2b8e047280ee360e6dc234f81710c77c5f9cb38bd08dc13690b358538d1e5')
+ 'd7ba38d5f35a6322b569e33a132eecf2fba36d4bc124ba75caa8e57f81753c20')
pkgver() {
cd ${pkgname%-git}
git describe --always | sed 's+[_-]+.+g' | sed 's+base+1+' | cut -c8-
}
-prepare() {
- cd ${pkgname%-git}
- git apply "$srcdir"/nohtml.patch
-}
-
build() {
cd ${pkgname%-git}
./bootstrap