summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50d92ce4afe2..a69bf3224f33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=maxima-git
-pkgver=5.46.1.1782.g9d3ad3bb7
+pkgver=5.47.1.111.g3f7ab0c6b
pkgrel=1
pkgdesc="Sophisticated computer algebra system - git-version"
arch=('i686' 'x86_64')
@@ -15,15 +15,21 @@ optdepends=('gnuplot: plotting capabilities'
provides=('maxima')
conflicts=('maxima')
options=('!makeflags' '!zipman')
-source=('maxima::git://git.code.sf.net/p/maxima/code' 'maxima.desktop')
+source=('maxima::git://git.code.sf.net/p/maxima/code' 'maxima.desktop' nohtml.patch)
sha256sums=('SKIP'
- 'd7ba38d5f35a6322b569e33a132eecf2fba36d4bc124ba75caa8e57f81753c20')
+ 'd7ba38d5f35a6322b569e33a132eecf2fba36d4bc124ba75caa8e57f81753c20'
+ 'd1a2b8e047280ee360e6dc234f81710c77c5f9cb38bd08dc13690b358538d1e5')
pkgver() {
cd ${pkgname%-git}
git describe --always | sed 's+[_-]+.+g' | sed 's+base+1+' | cut -c8-
}
+prepare() {
+ cd ${pkgname%-git}
+ git apply "$srcdir"/nohtml.patch
+}
+
build() {
cd ${pkgname%-git}
./bootstrap
@@ -36,7 +42,7 @@ build() {
package() {
cd ${pkgname%-git}
_pkgver=$(git describe --always | sed 's+-+_+g')
- make DESTDIR="$pkgdir/" \
+ make DESTDIR="$pkgdir" \
emacsdir=/usr/share/emacs/site-lisp/maxima install
install -Dm644 "$srcdir"/maxima.desktop \
"$pkgdir"/usr/share/applications/${pkgname}.desktop