summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5754da74c71e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Andrea Zanoni <andrea dot zanoni at polimi dot it>
+pkgname=mbdyn-git
+pkgver=r7415.ebbccab59
+pkgrel=1
+pkgdesc="The first *free* general purpose Multibody Dynamics analysis software"
+arch=('any')
+url='www.mbdyn.org'
+license=('GPLv2')
+depends=(openblas-lapack suitesparse netcdf netcdf-cxx)
+makedepends=(git autoconf automake gcc-fortran libtool)
+optdepends=('ginac: symbolic elements support')
+source=("${pkgname}::git+https://public.gitlab.polimi.it/DAER/mbdyn.git")
+sha256sums=('SKIP')
+
+# Note: edit the list of modules to suit your needs
+_modules="hfelem"
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+OPTIONS="--prefix=/usr --with-y12=no --with-lapack=yes --enable-python --enable-Werror=no --with-superlu=no"
+prepare() {
+ cd ${srcdir}/${pkgname}
+ git checkout develop
+ sh bootstrap.sh
+ CXXFLAGS="-O3 -march=native" \
+ FCFLAGS="-O3" \
+ CFLAGS="-O3 -march=native" \
+ ./configure \
+ --with-module="${_modules}" \
+ --prefix=/usr \
+ --with-y12=no \
+ --with-lapack=yes \
+ --enable-python \
+ --enable-Werror=no \
+ --with-superlu=no
+}
+
+build() {
+ cd ${srcdir}/${pkgname}
+ make -j$(nproc)
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ # make install
+ echo "Made it to install..."
+}