summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 33 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e476fb233855..187f7fa11542 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,47 @@
# Maintainer: Kozec <kozec at kozec dot com>
pkgname='mcedit'
-pkgver='0.1.8build799'
+reponame='MCEdit-Unified'
+pkgver='1.4.0.1'
pkgrel=1
pkgdesc='Minecraft world editor'
arch=('any')
url='https://github.com/mcedit/mcedit'
license='BSD'
-depends=('python2' 'python2-numpy' 'python2-opengl'
- 'python2-pygame' 'ttf-bitstream-vera' "pymclevel>=$pkgver")
+makedepends=('cython2')
+depends=('python2' 'python2-opengl' 'python2-numpy' 'python2-pygame'
+ 'python2-yaml' 'python2-pillow' 'python2-ftputil')
conflicts=('mcedit-git' 'pymclevel-git')
source=(MCEdit MCEdit.desktop
directories.patch
- disable-portable-mode.patch
numpy1.7-compatibility.patch
- filters-in-home.patch
- https://github.com/mcedit/mcedit/archive/${pkgver}.tar.gz
+ https://github.com/Khroki/${reponame}/archive/${pkgver}.tar.gz
)
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- # Provided setup.py depends on something weird, but I'm not even
- # going to bother.
-
+prepare() {
+ cd ${srcdir}/${reponame}-${pkgver}
+ grep -rlZ python2\.7 * | while IFS= read -r -d '' filename; do sed -i '1 s/python2\.7/python\.7/' "$filename"; done
+ grep -rlZ python * | while IFS= read -r -d '' filename; do sed -i '1 s/python/python2/' "$filename"; done
+ grep -rlZ DejaVuSans\-Regular\.ttf * | while IFS= read -r -d '' filename; do sed -i 's/DejaVuSans\-Regular\.ttf/DejaVuSans\.ttf/g' "$filename"; done
msg directories.patch
patch -Np0 -i ../directories.patch || return 1
- msg disable-portable-mode.patch
- patch -Np0 -i ../disable-portable-mode.patch || return 1
msg numpy1.7-compatibility.patch
- patch -Np1 -i ../numpy1.7-compatibility.patch || return 1
- msg filters-in-home.patch
- patch -Np0 -i ../filters-in-home.patch || return 1
+ patch -Np0 -i ../numpy1.7-compatibility.patch || return 1
+}
+
+
+build() {
+ cd ${srcdir}/${reponame}-${pkgver}
+ python2 config.py -auto
+ python2 setup.py build_ext --inplace
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${reponame}-${pkgver}
+ python2 setup.py install --prefix=/usr --root="$pkgdir/"
mkdir -p "${pkgdir}/usr/bin"
mkdir -p "${pkgdir}/usr/lib/mcedit"
mkdir -p "${pkgdir}/usr/share/mcedit"
@@ -46,12 +49,17 @@ package() {
mkdir -p "${pkgdir}/usr/share/pixmaps"
# Pys
cp *.py "${pkgdir}/usr/lib/mcedit"
- for i in albow editortools ; do
+ cp *.pyc "${pkgdir}/usr/lib/mcedit"
+ for i in albow editortools pymclevel utilities panels viewports; do
cp -R $i "${pkgdir}/usr/lib/mcedit/$i"
done
+
# Images and stuff
+ echo "/usr/share/mcedit/splashes/splash1.png" > splash
cp *.png "${pkgdir}/usr/share/mcedit"
- for i in stock-schematics toolicons filters; do
+ for i in stock-schematics toolicons stock-filters stock-brushes lang\
+ item-textures Items splashes splash bo3.def RELEASE-VERSION.json\
+ LR5_mzu.fot; do
cp -R $i "${pkgdir}/usr/share/mcedit/$i"
done
ln -s "/usr/share/mcedit/favicon.png" "${pkgdir}/usr/share/pixmaps/MCEdit.png"
@@ -61,10 +69,8 @@ package() {
install -D "${srcdir}/MCEdit.desktop" "${pkgdir}/usr/share/applications"
}
-md5sums=('b9de4195ddf84d85c0170e816ec0659e'
- 'e598244d2770ee075d397d6c11dc140d'
- '732f8e3faa3806a9fcdf8697b9d8d5d8'
- 'b8b5e679ed9bbf9f6a0e489599d2c587'
- 'a4f4e6645e0f00898fed0830127c727f'
- '5f84a8bf43e385e16f476fbd8ee4dc51'
- '8745d3b8bb4765755d2c31e539f6476d')
+md5sums=('b08f609c8923067b13a9bd462999a6f4'
+ '53fe3c41d58fd1f6429f90ba0b1831ac'
+ '657f128f31d8818c2fda7e2c02a69149'
+ '2a168455d07a33134b58e44bedeb6e52'
+ 'f89ddd094dc7819d54090d659d091e5b')