summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d83704b3533..91c8308ac93c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,19 @@
pkgname=mcmap
pkgver=3.0.2
-pkgrel=3
+pkgrel=4
pkgdesc="Pixel-art map visualizer for Minecraft. Maps are drawn from an isometric perspective. "
arch=('x86_64')
-url="https://github.com/spoutn1k/mcmap"
+url="https://github.com/spoutn1k/${pkgname}"
license=('GPL3')
depends=('zlib' 'libpng' 'spdlog' 'fmt' 'qt5-tools')
makedepends=('git' 'gcc' 'make' 'cmake')
+checkdepends=('gtest')
provides=('mcmap'
'mcmap-gui')
-source=("${pkgname}::git+https://github.com/spoutn1k/mcmap.git#tag=v${pkgver}"
+CFLAGS=('${CFLAGS} -U_GLIBCXX_ASSERTIONS')
+CXXFLAGS=('${CXXFLAGS} -U_GLIBCXX_ASSERTIONS')
+source=("${pkgname}::git+https://github.com/spoutn1k/${pkgname}.git#tag=v${pkgver}"
"${pkgname}.desktop")
sha256sums=('SKIP'
'67dff6174f3ef3c072560b6b2c161470d5f76a6282bf9bf6afa9d14750459714')
@@ -23,10 +26,17 @@ build() {
cmake ..
make mcmap mcmap-gui
}
+
+check() {
+ cd "${srcdir}/${pkgname}/build"
+ make run_tests
+ cd "${srcdir}/${pkgname}/build/bin" && ./run_tests
+}
+
package() {
install -Dm755 "${srcdir}/${pkgname}/build/bin/mcmap" "${pkgdir}/usr/bin/mcmap"
install -Dm755 "${srcdir}/${pkgname}/build/bin/mcmap-gui" "${pkgdir}/usr/bin/mcmap-gui"
install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "${srcdir}/${pkgname}/src/graphical/icons/grass_block.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname}/src/graphical/icons/grass_block.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}