summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD70
1 files changed, 34 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a7e0616696d..0d6cb797804a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,50 @@
-# Maintainer: dysphoria <>
+# Maintainer: TH Campbell (dysphoria) <thcampbell (at) protonmail (dot) com>
+# Contributor: Justin Wong <jusw85 at hotmail dot com>
+# Contributor: Matt Parnell/ilikenwf <parwok@gmail.com>
# Contributor: Mitsu <archlinux AT suumitsu DOT eu>
# Contributor: schuay <jakob.gruber@gmail.com>
# Contributor: Ray Powell <ray_al@xphoniexx.net>
pkgname=mcomix-git
-pkgver=r1494.0b5e6d4
-pkgrel=1
-pkgdesc="A user-friendly, customizable image viewer specifically designed to handle comic books"
+pkgver=3.0.0.r16.g4a91687
+pkgrel=2
+pkgdesc='A user-friendly, customizable image viewer specifically designed to handle comic books'
arch=('any')
-url="https://sourceforge.net/projects/mcomix/"
+url='https://sourceforge.net/projects/mcomix/'
license=('GPL')
-depends=('pygtk' 'python2-pillow' 'xdg-utils' 'python2' \
- 'desktop-file-utils' 'hicolor-icon-theme' 'python2-setuptools')
-makedepends=('gettext' 'intltool')
-optdepends=('libunrar: for rar compressed comics' \
- 'p7zip: for 7z compressed comics' \
- 'unrar: for rar compressed comics' \
- 'unzip: for zip compressed comics' \
- 'mupdf: for PDF comics')
-provides=("mcomix")
-conflicts=("mcomix")
-source=("${pkgname}::git+http://git.code.sf.net/p/mcomix/git"
- 'save_as_tweaks_1.3.patch')
-sha256sums=('SKIP'
- '10fcc2045e49dac348de37d9ea8d0491b6d74300267396054a913ffac8fefdab')
-install=${pkgname}.install
+depends=('gtk3' 'python-pillow>=6.0.0' 'xdg-utils' 'python>=3.7'
+ 'desktop-file-utils' 'hicolor-icon-theme'
+ 'python-gobject>=3.36.0' 'python-cairo>=1.16.0')
+makedepends=('gettext' 'intltool' 'git' 'python-setuptools' 'python-wheel' 'python-build' 'python-installer')
+optdepends=(
+ 'libunrar: for rar compressed comics'
+ 'p7zip: for 7z compressed comics'
+ 'unrar: for rar compressed comics'
+ 'unzip: for zip compressed comics'
+ 'lhasa: for lha compressed comics'
+ 'mupdf: for PDF comics'
+ )
+provides=('mcomix')
+conflicts=('mcomix')
+source=(
+ "${pkgname}::git+http://git.code.sf.net/p/mcomix/git"
+ )
+sha256sums=('SKIP')
pkgver() {
- cd "${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${pkgname}"
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "${pkgname}"
- patch -Np1 -i "${srcdir}/save_as_tweaks_1.3.patch"
+build() {
+ cd "${pkgname}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${pkgname}"
- mkdir -p ${pkgdir}/usr
- export PYTHONPATH=${pkgdir}/usr/lib/python2.7/site-packages/
- mkdir -p $PYTHONPATH
- python2 setup.py install --prefix=/usr --optimize=1 \
- --single-version-externally-managed --root="${pkgdir}/"
+ cd "${pkgname}"
- install -Dm755 mime/comicthumb ${pkgdir}/usr/bin/comicthumb
- install -Dm644 mime/comicthumb.1.gz ${pkgdir}/usr/share/man/man1/comicthumb.1.gz
- install -Dm644 mime/comicthumb.thumbnailer ${pkgdir}/usr/share/thumbnailers/comicthumb.thumbnailer
- install -Dm644 mime/comicbook.schemas ${pkgdir}/usr/share/gconf/schemas/mcomix.schemas
-}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ cp -a share "${pkgdir}/usr"
+}