summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72b234aaf73d..2dbae97405d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=mcomix-git
_gitname=mcomix
-pkgver=20150907
+pkgver=r1396.9ed169d
pkgrel=1
pkgdesc="A user-friendly, customizable image viewer specifically designed to handle comic books"
arch=('any')
@@ -25,6 +25,11 @@ source=('git+https://github.com/benoit-pierre/mcomix.git')
sha256sums=('SKIP')
install=mcomix.install
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package() {
cd "${srcdir}/${_gitname}"
mkdir -p ${pkgdir}/usr