summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c59daf6570e9..9a7e0616696d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Ray Powell <ray_al@xphoniexx.net>
pkgname=mcomix-git
-pkgver=r1488.30700bf
+pkgver=r1494.0b5e6d4
pkgrel=1
pkgdesc="A user-friendly, customizable image viewer specifically designed to handle comic books"
arch=('any')
@@ -20,8 +20,10 @@ optdepends=('libunrar: for rar compressed comics' \
'mupdf: for PDF comics')
provides=("mcomix")
conflicts=("mcomix")
-source=("${pkgname}::git+http://git.code.sf.net/p/mcomix/git")
-sha256sums=('SKIP')
+source=("${pkgname}::git+http://git.code.sf.net/p/mcomix/git"
+ 'save_as_tweaks_1.3.patch')
+sha256sums=('SKIP'
+ '10fcc2045e49dac348de37d9ea8d0491b6d74300267396054a913ffac8fefdab')
install=${pkgname}.install
pkgver() {
@@ -29,6 +31,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${pkgname}"
+ patch -Np1 -i "${srcdir}/save_as_tweaks_1.3.patch"
+}
+
package() {
cd "${srcdir}/${pkgname}"
mkdir -p ${pkgdir}/usr