summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af6c29072218
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=mcstatus
+pkgver=git
+pkgrel=1
+pkgdesc="A Minecraft server status probing library"
+arch=('x86_64' 'i686')
+url="https://github.com/MoeLeak/mcstatus"
+license=('MIT')
+depends=('cmake' 'boost' 'clang')
+#install=mcstatus.install
+source=("$pkgname::git+https://github.com/MoeLeak/mcstatus.git")
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+ cmake .
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir/" install
+}