summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 090a8cb401df..eedcf6cc1110 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,38 @@
-# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Maintainer: Patrick Louis <patrick at unixhub dot net>
+# Contributor: Brian Bidulock <bidulock@openss7.org>
pkgname=mcwm-git
-pkgver=20130209.2.r11.gee7d9df
-pkgrel=3
+pkgver=20130209.2.5
+pkgrel=1
pkgdesc="A minimalist floating window manager written on top of the XCB"
arch=('i686' 'x86_64')
-#url="http://hack.org/mc/hacks/mcwm/"
-url="https://github.com/bbidulock/mcwm"
+url="http://hack.org/mc/hacks/mcwm/"
license=('ISC')
-depends=('xcb-util-wm' 'xcb-util-keysyms' 'bash')
+depends=('xcb-util' 'xcb-util-wm' 'xcb-util-keysyms')
makedepends=('git')
provides=('mcwm')
-conflicts=('mcwm' '2bwm' '2bwm-git') # because of /usr/bin/hidden program
-source=("$pkgname::git+https://github.com/bbidulock/mcwm.git" "mcwm.desktop")
+conflicts=('mcwm')
+source=("$pkgname::git://hack.org/mcwm" "mcwm.desktop")
md5sums=('SKIP'
'8daed020f1a9df4b774207b30d954c53')
pkgver() {
cd $pkgname
- git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ git describe --tags | sed 's,[-_],.,g;s,\.g.*$,,'
}
prepare() {
cd $pkgname
- ./autogen.sh
+ sed -i 's,/man/man1,/share/man/man1,' Makefile
}
build() {
cd $pkgname
- ./configure --prefix=/usr --libexecdir=/usr/lib
- make V=0
+ LDFLAGS+=" -Wl,--no-as-needed"
+ make
}
package() {
cd $pkgname
- make DESTDIR="$pkgdir" install
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/man/man1"
+ make "PREFIX=$pkgdir/usr" install
install -Dm644 "$srcdir/mcwm.desktop" "$pkgdir/usr/share/xsessions/mcwm.desktop"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}