summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf5feac71a65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: atomicfs
+
+pkgname=mdbook-footnote
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="A preprocessor for mdbook to support the inclusion of footnotes"
+url="https://github.com/daviddrysdale/mdbook-footnote"
+arch=(x86_64)
+license=(MIT)
+makedepends=(rust cargo)
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('c5a76a6dbb4a27bff9dfae4398c32497206c3667d70aa7ec8f32a7d98ab11a83')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cargo build --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm 755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}
+