summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f72def40129..2b6e660247e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Generated by debtap
-# Maintainer: ajiepangestu
-# Contributor:
+# Maintainer: justanoobcoder <syaorancode@gmail.com>
+
+_github_user="hainguyents13"
+_github_repo="mechvibes"
+
pkgname=mechvibes
-pkgver=2.3.0
+pkgver=2.3.4
pkgrel=1
pkgdesc="Play mechanical keyboard sounds as you type."
arch=('x86_64')
url="https://mechvibes.com"
-license=('GNU')
-groups=('')
+license=('MIT')
depends=('alsa-lib' 'atk' 'at-spi2-atk' 'at-spi2-core' 'cairo' 'dbus' 'desktop-file-utils' 'expat' 'gdk-pixbuf2' 'glib2' 'gtk3' 'hicolor-icon-theme' 'libappindicator-gtk3' 'libcups' 'libnotify' 'libsecret' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nspr' 'nss' 'pango' 'util-linux-libs' 'xdg-utils')
options=('!strip' '!emptydirs')
install=${pkgname}.install
-source=("https://github.com/hainguyents13/mechvibes/releases/download/v${pkgver}/mechvibes_${pkgver}_amd64.deb")
-md5sums=('953bf957b816a0f1c140e1b6b0b57065')
+source=("https://github.com/${_github_user}/${_github_repo}/releases/download/v${pkgver}/${pkgname}_${pkgver}_amd64.deb")
+md5sums=('470f65983c996aac5b48beaaf0cd4ae8')
-package(){
+package() {
# Extract package data
tar xf data.tar.xz -C "${pkgdir}"
# Install Icon
for i in 16x16 24x24 32x32 48x48 64x64 128x128 256x256; do
- install -Dm644 "$pkgdir"/usr/share/icons/hicolor/0x0/"$pkgname".png \
- "$pkgdir"/usr/share/icons/hicolor/"$i"/"$pkgname".png
+ install -Dm644 "$pkgdir"/usr/share/icons/hicolor/0x0/apps/"$pkgname".png \
+ "$pkgdir"/usr/share/icons/hicolor/"$i"/apps/"$pkgname".png
done
}