summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5675de38e79..8f8a1536c935 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=('med' 'med-docs')
pkgver=4.0.0
-pkgrel=6
+pkgrel=7
pkgdesc="Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5. Without openmpi."
url="https://www.salome-platform.org/downloads"
license=('LGPL')
@@ -9,19 +9,22 @@ makedepends=('gcc-fortran' 'swig' 'cmake')
optdepends=()
arch=('x86_64')
source=("http://files.salome-platform.org/Salome/other/${pkgname}-${pkgver}.tar.gz"
- "https://gist.githubusercontent.com/jedbrown/527ef81ff59a0dccf833da40fdd15a47/raw/7482f9a42fdd277f5f9cf0167ea7a3381032ca7a/hdf5-1.12.patch")
+ "https://gist.githubusercontent.com/jedbrown/527ef81ff59a0dccf833da40fdd15a47/raw/7482f9a42fdd277f5f9cf0167ea7a3381032ca7a/hdf5-1.12.patch"
+ "pycompile.patch")
sha256sums=('a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004'
- '82d28b6ae2ee6ceb3c6de9acb861a49741e2e759c7c556217f7d284216788206')
+ '82d28b6ae2ee6ceb3c6de9acb861a49741e2e759c7c556217f7d284216788206'
+ 'fec659efc391376eeb73c2e749d98ae504a178dde2d2e9d7b81d26537a043300')
prepare() {
cd ${pkgbase}-${pkgver}
patch -p1 -i "$srcdir/hdf5-1.12.patch"
+ patch -p1 -i "$srcdir/pycompile.patch"
}
build() {
cd ${pkgname}-${pkgver}
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
- -DMEDFILE_BUILD_PYTHON=ON .
+ -DMEDFILE_BUILD_PYTHON=ON -DMEDFILE_BUILD_TESTS=OFF .
make
}