summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD91
1 files changed, 27 insertions, 64 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4af23cbc8094..887f7c716fae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,75 +1,38 @@
-# Maintainer Oliver Goethel <deezy>
-# Contributor: Michele Mocciola <mickele>
-# Contributor: Brice Méalier <mealier_brice@yahoo.fr>
-# Contributor: Philippe Miron <tuxication@gmail.com>
-# Modified by: César Vecchio <cesar UNDERSTRIKE vecchio AT yahoo DOT com>
-# Modified by: Martin Ortbauer <mortbauer@gmail.com>
-
pkgname=med
-pkgver=3.2.0
-pkgrel=5
+pkgver=3.3.1
+pkgrel=1
pkgdesc="MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - MED is code-aster exchange module linked to hdf5"
url="http://www.code-aster.org/outils/med/"
license=('LGPL')
depends=('hdf5' 'openmpi' 'swig')
-makedepends=('gcc-fortran' 'coreutils' 'python2')
+makedepends=('gcc-fortran' 'python2')
optdepends=('tk')
-provides=()
-conflicts=('med_fichier')
-replaces=('med_fichier')
-backup=()
-arch=('i686' 'x86_64')
+arch=('x86_64')
source=("http://files.salome-platform.org/Salome/other/${pkgname}-${pkgver}.tar.gz"
- "patch-include_2.3.6_med.h.in"
- "patch-include_med.h.in"
- "patch-src_2.3.6_ci_MEDequivInfo.c"
- "patch-int2long")
-md5sums=('eb61df92f0624feb6328f517cd756a23'
- 'b83949326d7ae0ca77a06822b754a329'
- '14a151cea108388d7a3b4c62887169f6'
- '8f0cbf6f08783a6ba68ff5ab240dd62e'
- 'be65d145b85ed5b19a709d9dee84b6d2')
-
-build() {
- if [ "$CARCH" = "x86_64" ]; then
- export FFLAGS="-fopenmp -fPIC -fdefault-double-8 -fdefault-integer-8 -fdefault-real-8 -ffixed-line-length-0 ${CFLAGS}"
- export FCFLAGS="-fopenmp -fPIC -fdefault-double-8 -fdefault-integer-8 -fdefault-real-8 -ffixed-line-length-0 ${CFLAGS}"
- export CPPFLAGS="-DHAVE_F77INT64 ${CPPFLAGS}"
- export F77=mpif90
- export FC=mpif90
- else # i686
- export FFLAGS="-fopenmp -fPIC -ffixed-line-length-0 ${CFLAGS}"
- export FCFLAGS="-fopenmp -fPIC -ffixed-line-length-0 ${CFLAGS}"
- export F77=mpif90
- export FC=mpif90
- fi
-
- export PYTHON="$(which python2)"
+ "hdf5-1.10-support.patch")
+sha256sums=('dd631ef813838bc7413ff0dd6461d7a0d725bcfababdf772ece67610a8d22588'
+ '55cf95f1a3b7abf529bb2ded6c9a491459623c830dc16518058ff53ab203291c')
- cd ${srcdir}/${pkgname}-${pkgver} || return 1
-
- # patch H5public_extract.h.in
- sed -i -e '/^#typedef/ s/#/\/\//' ./include/H5public_extract.h.in
-
- #patch for hdf5-1.10
- patch -p0 < ${srcdir}/patch-include_2.3.6_med.h.in
- patch -p0 < ${srcdir}/patch-include_med.h.in
- patch -p0 < ${srcdir}/patch-src_2.3.6_ci_MEDequivInfo.c
- patch -p0 < ${srcdir}/patch-int2long
-
- ./configure --with-f90=mpif90 --prefix=/usr --datadir=/usr/share/med --with-swig=yes || return 1
- make || return 1
+prepare () {
+ cd ${srcdir}/${pkgname}-${pkgver}_SRC
+ # https://salsa.debian.org/science-team/med-fichier/tree/master/debian/patches
+ patch -p1 -i "${srcdir}"/hdf5-1.10-support.patch
+ autoreconf -vfi
}
-
-package() {
- cd ${srcdir}/${pkgname}-${pkgver} || return 1
-
- make DESTDIR=${pkgdir} install || return 1
- # now move the testprograms to share, we don't want all the stuff in the bindir
- cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/testc ${pkgdir}/usr/share/med/testc
- cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/testf ${pkgdir}/usr/share/med/
- cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/unittests ${pkgdir}/usr/share/med/
- cp -dpr --no-preserve=ownership ${pkgdir}/usr/bin/usescases ${pkgdir}/usr/share/med/
- rm -r ${pkgdir}/usr/bin/{usescases,unittests,testf,testc}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}_SRC
+ export FFLAGS="-fopenmp -fPIC -fdefault-double-8 -fdefault-integer-8 -fdefault-real-8 -ffixed-line-length-0 ${CFLAGS}"
+ export FCFLAGS="-fopenmp -fPIC -fdefault-double-8 -fdefault-integer-8 -fdefault-real-8 -ffixed-line-length-0 ${CFLAGS}"
+ export CPPFLAGS="-DHAVE_F77INT64 ${CPPFLAGS}"
+ export F77=mpif90
+ export FC=mpif90
+ export PYTHON=/usr/bin/python2
+ ./configure --with-f90=mpif90 --prefix=/usr --datadir=/usr/share/med --with-swig=yes
+ make
}
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}_SRC
+ make DESTDIR=${pkgdir} install
+}