summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8ed549a9be6..600b9d6ff679 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
pkgname=meep-git
-pkgver=1.3.r125.gfc1b6b0
-pkgrel=2
+pkgver=1.4.3.r6.gd5d92dd
+pkgrel=1
pkgdesc='Free finite-difference time-domain (FDTD) software for electromagnetic simulations (includes python interface)'
arch=('i686' 'x86_64')
url='https://github.com/stevengj/meep'
@@ -9,8 +9,8 @@ license=('GPL2')
depends=('harminv-git' 'libctl-git' 'hdf5' 'gsl' 'fftw' 'openmpi' 'swig' 'python-numpy')
makedepends=('gcc-fortran' 'suitesparse')
optdepends=('h5utils: visualization and conversion of scientific data'
- 'python-h5py: process HDF5 data from python'
- 'python-mpi4py: use MPI from the python interface'
+ 'python-h5py: process HDF5 data from python'
+ 'python-mpi4py: use MPI from the python interface'
'mpb-git: calculation of electromagnetic modes')
options=('!libtool' '!makeflags')
provides=('meep')
@@ -25,10 +25,8 @@ pkgver() {
build() {
cd "${srcdir}/meep"
- sed -i '/unknown argument/d' autogen.sh
./autogen.sh --prefix=/usr --enable-shared --with-mpi --with-python
make
- sed -i -e "s/__name__\.rpartition.*/__name__/" python/__init__.py
}
package() {