summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 446623e2aa88..51a751de9ed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=megasync
pkgver=3.1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Sync your files to your Mega account. Official app"
arch=('i686' 'x86_64')
url="https://github.com/meganz/megasync"
@@ -11,12 +11,16 @@ license=('custom:MEGA LIMITED CODE REVIEW LICENCE')
depends=('curl' 'c-ares' 'crypto++' 'libsodium' 'hicolor-icon-theme' 'qt5-base' 'libuv' 'openssl')
makedepends=('git' 'qt5-tools' 'swig' 'doxygen')
optdepends=('sni-qt: fix systray issue on KDE and LXQt')
-source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}_Linux")
-md5sums=('SKIP')
+source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}_Linux"
+ "ucontext.patch")
+md5sums=('SKIP'
+ '269c3d2ff3e911774c2cc8e6de980cb2')
prepare(){
cd "${srcdir}/MEGAsync"
git submodule update --init --recursive
+
+ patch -p1 < "${srcdir}/ucontext.patch"
}
build(){