summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd8c77f94fb5..485c59e4f2c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
# Maintainer: Matteo Salonia <saloniamatteo@protonmail.com>
pkgname=memethesis-cli
-pkgver=3.2.1
+pkgver=3.3.0
pkgrel=1
pkgdesc="Create memes from the terminal"
arch=('any')
url="https://github.com/fakefred/memethesis-cli"
license=('GPL3')
depends=('python>=3' 'imagemagick')
-source=("https://github.com/fakefred/memethesis-cli/archive/3.2.1.tar.gz")
-sha256sums=("3c0b1727bdc8e7c39885cdbfcdf6bc1daeae84b8be4780c756f053e42a37e31c")
+makedepends=('git')
+# 3.2.1 is the version that can be downloaded in the releases
+# We will be using 3.3.0 but we'll have to clone the entire repo
+#source=("https://github.com/fakefred/memethesis-cli/archive/3.2.1.tar.gz")
+#sha256sums=("3c0b1727bdc8e7c39885cdbfcdf6bc1daeae84b8be4780c756f053e42a37e31c")
+source=("git+https://github.com/fakefred/${pkgname}.git")
+sha256sums=("SKIP")
package() {
- # go into memethesis-cli-3.2.1-1
- cd "${srcdir}/${pkgname}-${pkgver}"
+ # go into memethesis-cli
+ cd "${srcdir}/${pkgname}"
# install memethesis-cli; binary is in /usr/bin/memethesis
python3 setup.py install --root="$pkgdir"
}