summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 485c59e4f2c4..9bf0e28bd7f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Create memes from the terminal"
arch=('any')
url="https://github.com/fakefred/memethesis-cli"
license=('GPL3')
-depends=('python>=3' 'imagemagick')
+depends=('python>=3' 'python-pip' 'imagemagick')
makedepends=('git')
# 3.2.1 is the version that can be downloaded in the releases
# We will be using 3.3.0 but we'll have to clone the entire repo
@@ -16,6 +16,11 @@ makedepends=('git')
source=("git+https://github.com/fakefred/${pkgname}.git")
sha256sums=("SKIP")
+prepare() {
+ # install python dependencies
+ pip3 install PyYAML Pillow PyInquirer colored ascim
+}
+
package() {
# go into memethesis-cli
cd "${srcdir}/${pkgname}"