summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4c46e7509f0..ab0f9fc09af5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=menyoki-git
-pkgver=1.5.1.r0.ge29709f
+pkgver=1.5.3.r0.g51bc46b
pkgrel=1
pkgdesc="Screen{shot,cast} and perform ImageOps on the command line (git)"
arch=('x86_64')
@@ -21,14 +21,19 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${pkgname%-git}"
+ cargo fetch --locked
+}
+
build() {
cd "${pkgname%-git}"
- cargo build --release --locked
+ cargo build --release --frozen
}
check() {
cd "${pkgname%-git}"
- cargo test --release --locked
+ cargo test --frozen
}
package() {