summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41be6c6a9646..408c00d4d930 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mermaid-cli
pkgver=8.9.2
-pkgrel=2
+pkgrel=3
pkgdesc='Generation of diagram and flowchart from text in a similar manner as markdown (CLI)'
arch=('any')
url='https://github.com/mermaid-js/mermaid-cli'
@@ -17,13 +17,13 @@ sha256sums=('29082de0a5c57a191406e18736554bc2388f7e4c18d3b58db061598a11813df0')
noextract=("${_npmname}-${_npmver}.tgz")
package() {
- npm install --global --production --user root --prefix "${pkgdir}/usr" "${_npmname}-${_npmver}.tgz"
+ npm install --global --production --prefix "${pkgdir}/usr" "${_npmname}-${_npmver}.tgz"
# -> https://wiki.archlinux.org/index.php/Node.js_package_guidelines
# Non-deterministic race in npm gives 777 permissions to random directories.
- # See https://github.com/npm/npm/issues/9359 for details.
- find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+ # See https://github.com/npm/cli/issues/1103 for details.
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
# npm gives ownership of ALL FILES to build user
# https://bugs.archlinux.org/task/63396
- chown -R root:root "$pkgdir"
+ chown -R root:root "${pkgdir}"
}