summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbdb4cb83d8b..b47aaee13742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=mesa-minimal-git
pkgname=(mesa-minimal-git opencl-rusticl-mesa-minimal-git)
pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
-pkgver=24.2.0_devel.189258.5502ecd7716
+pkgver=24.2.0_devel.189613.18c736bcfc5
pkgrel=1
arch=('x86_64')
makedepends=(git meson ninja libglvnd python-packaging python-mako xorgproto libxml2 libx11 libva elfutils libxrandr
@@ -29,11 +29,15 @@ url="https://www.mesa3d.org"
license=('custom')
source=("mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git"
'LICENSE'
+ '29275.patch'
)
+
md5sums=('SKIP'
- '5c65a0fe315dd347e09b1f2826a1df5a')
+ '5c65a0fe315dd347e09b1f2826a1df5a'
+ 'af51dce4950cdeacc5ddea2fd1685a6e')
sha512sums=('SKIP'
- '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2')
+ '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
+ '81a368f7e44841c1b24f9a25d528bad07293855cce439d9a4790d12c1cfb363b84674fabf2bd56049ed07d43701e5c0d251fdade697388a50c785983147b3feb')
options=(!emptydirs !lto !debug)
@@ -42,6 +46,12 @@ options=(!emptydirs !lto !debug)
# The responsibility to validate the value of NINJAFLAGS lies with the user.
# If unsure, use NINJAFLAGS=""
+prepare() {
+ # https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/29275
+ patch --directory=mesa --forward --strip=1 --input="$srcdir"/29275.patch
+
+}
+
pkgver() {
cd mesa
local _ver