summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 572dde57e7c9..cce755675ee2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributer: mickael9 <mickael9 at gmail dot com>
_number_of_bits=16
-pkgver=1.60
+pkgver=1.61
pkgname=microchip-mplabxc${_number_of_bits}-bin
pkgrel=1
pkgdesc="Microchip's MPLAB XC${_number_of_bits} C compiler toolchain for their dsPIC and PIC24 microcontroller families"
@@ -12,18 +12,12 @@ url=http://www.microchip.com/xc${_number_of_bits}
license=(custom)
depends_i688=(gcc-libs)
depends_x86_64=(lib32-gcc-libs)
-makedepends=(sdx)
-makedepends_x86_64=(tclkit)
-makedepends_i686=(tclkit)
-makedepends_x86_64=(lib32-expat)
+makedepends=(bitrock-unpacker)
options=(!strip docs libtool emptydirs !zipman staticlibs)
-source=("http://ww1.microchip.com/downloads/en/DeviceDoc/xc${_number_of_bits}-v$pkgver-full-install-linux64-installer.run" "bitrock-unpacker.tcl")
+source=("http://ww1.microchip.com/downloads/en/DeviceDoc/xc${_number_of_bits}-v$pkgver-full-install-linux64-installer.run")
-sha256sums=('7d0e8dff22eff8085296081a1a2d4563268bfecdab83c81ce019e9f3b67a58ea'
- '1bcb58cdbb6e4a89415cf91cb6692aa0ada3abb41d22134510f8477ffd90b8a2')
-#md5sums=('98e2a50d75bdb0164b0c4cd82d1d6c74'
-# '70dedba4c417f8c0bb07c32d19e9d197')
+sha256sums=('5a2d2f8495adf9688dab8d5d69fedeeed25e266b77fccdedd9325b9094133448')
install=$pkgname.install
instdir="/opt/microchip/xc${_number_of_bits}/v${pkgver}"
@@ -32,7 +26,7 @@ PKGEXT='.pkg.tar'
build() {
msg2 "Unpacking files from installer"
- ./bitrock-unpacker.tcl ./xc${_number_of_bits}-v$pkgver-full-install-linux64-installer.run ./unpacked.vfs
+ bitrock-unpacker ./xc${_number_of_bits}-v$pkgver-full-install-linux64-installer.run ./unpacked.vfs
}
package() {