summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22eec4521176..89584597be4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_number_of_bits=16
pkgname=microchip-mplabxc${_number_of_bits}-bin
-pkgver=1.41
+pkgver=1.50
pkgrel=1
pkgdesc="Microchip's MPLAB XC${_number_of_bits} C compiler toolchain for their dsPIC and PIC24 microcontroller families"
arch=(i686 x86_64)
@@ -13,14 +13,17 @@ license=(custom)
depends_i688=(gcc-libs)
depends_x86_64=(lib32-gcc-libs)
makedepends=(sdx)
-makedepends_x86_64=(lib32-tclkit)
+makedepends_x86_64=(tclkit)
makedepends_i686=(tclkit)
+makedepends_x86_64=(lib32-expat)
options=(!strip docs libtool emptydirs !zipman staticlibs)
-source=("http://ww1.microchip.com/downloads/en/DeviceDoc/xc${_number_of_bits}-v$pkgver-full-install-linux-installer.run" "bitrock-unpacker.tcl")
+source=("http://ww1.microchip.com/downloads/en/DeviceDoc/xc${_number_of_bits}-v$pkgver-full-install-linux64-installer.run" "bitrock-unpacker.tcl")
-md5sums=('98e2a50d75bdb0164b0c4cd82d1d6c74'
- '70dedba4c417f8c0bb07c32d19e9d197')
+sha256sums=('693f4c30c25701561d708a7ab984200b37e296597fffa680b3848a86cb534c02'
+ '1bcb58cdbb6e4a89415cf91cb6692aa0ada3abb41d22134510f8477ffd90b8a2')
+#md5sums=('98e2a50d75bdb0164b0c4cd82d1d6c74'
+# '70dedba4c417f8c0bb07c32d19e9d197')
install=$pkgname.install
instdir="/opt/microchip/xc${_number_of_bits}/v${pkgver}"
@@ -29,7 +32,7 @@ PKGEXT='.pkg.tar'
build() {
msg2 "Unpacking files from installer"
- ./bitrock-unpacker.tcl ./xc${_number_of_bits}-v$pkgver-full-install-linux-installer.run ./unpacked.vfs
+ ./bitrock-unpacker.tcl ./xc${_number_of_bits}-v$pkgver-full-install-linux64-installer.run ./unpacked.vfs
}
package() {