summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a99094e81d1f..0ffa558818c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=migraphx
-pkgver=0.5.1
+pkgver=3.5.0
pkgrel=1
pkgdesc="AMD's graph optimization engine"
arch=('x86_64')
@@ -8,16 +8,15 @@ url="https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/"
license=('MIT')
depends=('rocm-cmake' 'miopen' 'hip' 'protobuf' 'half' 'pybind11')
makedepends=('cmake')
-source=("migraphx-$pkgver.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/$pkgver.tar.gz")
-sha256sums=('2079dfe2e1efbe5e56015e056bf82f90d1645fa4a2610e20afa861697616e6af')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-$pkgver.tar.gz")
+sha256sums=('5766f3b262468c500be5051a056811a8edfa741734a5c08c4ecb0337b7906377')
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm/migraphx \
- "$srcdir/AMDMIGraphX-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/migraphx \
+ "$srcdir/AMDMIGraphX-rocm-$pkgver"
make
}