summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e93c50e26a7..0e18528c6944 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer: ROllerozxa (temporaryemail4meh [gee mail])
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
pkgname=minetest-whynot
+_pkgname=whynot_game
+_pkgauthor=bell07
pkgver=2021.02.12
-_pkgver=6511
+_cdbrel=6511
pkgrel=1
-pkgdesc="Aims to get all existing high quality mods working together"
-arch=("any")
-url="https://content.minetest.net/packages/bell07/whynot_game/"
+pkgdesc="Aims to get all existing high quality mods working together "
license=("GPLv3")
-depends=("minetest-common")
-source=("whynot-$_pkgver.zip::https://content.minetest.net/packages/bell07/whynot_game/releases/${_pkgver}/download/")
sha256sums=('e7fcd73aeae0d7becc43869d0b5555c3981ec5f79847390dd3eb5727deb7634d')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
+depends=("minetest-common")
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
package() {
- cd whynot_game
- find . -type f | while read f; do
- install -Dm644 "$f" "${pkgdir}/usr/share/minetest/games/whynot/$f"
- done
+ install -d "${pkgdir}/usr/share/minetest/games/"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/"
}