summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7277588b69fa..6083c3be8f32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Daniel Kirchner <daniel@ekpyron.org>
pkgname=mingw-w64-boost
-pkgver=1.60.0
+pkgver=1.61.0
_boostver=${pkgver//./_}
pkgrel=1
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
@@ -10,11 +10,11 @@ url="http://www.boost.org/"
license=('custom')
depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-bzip2')
makedepends=('mingw-w64-gcc' 'bzip2' 'zlib' 'python2')
-options=(!strip !buildflags staticlibs)
+options=('!strip' '!buildflags' 'staticlibs')
source=("http://downloads.sourceforge.net/boost/boost/${pkgver}/boost_${_boostver}.tar.bz2"
- boost-mingw.patch)
-md5sums=('65a840e1a0b13a558ff19eeb2c4f0cbe'
- '30f8a21c4835ab0e729a1b7f08137bc1')
+ "boost-mingw.patch")
+md5sums=('6095876341956f65f9d35939ccea1a9f'
+ '3cf0110f7eac62f57178515c7dee9b66')
_architectures="32:i686-w64-mingw32 64:x86_64-w64-mingw32"
@@ -24,6 +24,11 @@ prepare() {
# https://svn.boost.org/trac/boost/ticket/7262
patch -Np0 -i "${srcdir}"/boost-mingw.patch
+ # https://svn.boost.org/trac/boost/ticket/12205
+ cd libs/serialization
+ wget -c https://github.com/boostorg/serialization/pull/42.patch
+ patch -p1 -i 42.patch
+
cd "${srcdir}"
for _arch in ${_architectures}; do
rm -rf build-${_arch:3}