summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aff2d274cb62..41a82085d366 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mingw-w64-chrono-date
pkgver=2.4.1+134+g9a0ee25
-pkgrel=3
+pkgrel=4
pkgdesc="A date and time library based on the C++11/14/17 <chrono> header"
arch=('any')
url="https://howardhinnant.github.io/date/date.html"
@@ -23,9 +23,11 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
# https://github.com/Alexays/Waybar/issues/565) are present with the tagged
# stable version.
source=("$pkgname::git+https://github.com/HowardHinnant/date#commit=9a0ee2542848ab8625984fc8cdbfb9b5414c0082"
- "538-output-date-pc-for-pkg-config.patch::https://patch-diff.githubusercontent.com/raw/HowardHinnant/date/pull/538.patch")
+ "538-output-date-pc-for-pkg-config.patch::https://patch-diff.githubusercontent.com/raw/HowardHinnant/date/pull/538.patch"
+ "use-correct-path-for-cmake-files.patch")
sha256sums=('SKIP'
- 'f39ce7f1f738ebdc02948ed78be68cca10c01f9e22a4243670304eeda53a03fd')
+ 'f39ce7f1f738ebdc02948ed78be68cca10c01f9e22a4243670304eeda53a03fd'
+ '0cf34f1c8efa949ba9d3c983d9032c114eaa99c5b5790bc9d5872aaaf0438120')
pkgver() {
cd "$pkgname"
@@ -36,6 +38,8 @@ prepare() {
cd "$pkgname"
# https://github.com/HowardHinnant/date/issues/537
patch -p1 < ../538-output-date-pc-for-pkg-config.patch
+
+ patch -p1 < ../use-correct-path-for-cmake-files.patch
}
build() {
@@ -69,8 +73,6 @@ package() {
cd "$pkgname"
for _arch in ${_architectures}; do
make -C build-${_arch} DESTDIR="$pkgdir/" install
- install -d 755 "$pkgdir/usr/${_arch}/lib/cmake"
- mv "$pkgdir/usr/${_arch}/CMake" "$pkgdir/usr/${_arch}/lib/cmake/date"
done
install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"