summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 16 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af56ba584032..818056e8fee7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,35 @@
-
pkgname=mingw-w64-cminpack
-pkgver=1.3.6
-pkgrel=1
+pkgver=1.3.8
+pkgrel=2
pkgdesc="A C/C++ rewrite of the MINPACK software (mingw-w64)"
arch=('any')
url='http://devernay.free.fr/hacks/cminpack/cminpack.html'
-license=('GPL' 'LGPL')
-depends=('mingw-w64-crt' 'mingw-w64-cblas')
+license=('BSD')
+depends=('mingw-w64-cblas')
makedepends=('mingw-w64-cmake')
options=('!buildflags' 'staticlibs' '!strip')
-source=("http://devernay.free.fr/hacks/cminpack/cminpack-${pkgver}.tar.gz")
-md5sums=('2c7f81105f94ea9268617a1748cc3506')
+source=("https://github.com/devernay/cminpack/archive/v${pkgver}.tar.gz")
+sha256sums=('3ea7257914ad55eabc43a997b323ba0dfee0a9b010d648b6d5b0c96425102d0e')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-build() {
+prepare () {
cd $srcdir/cminpack-${pkgver}
- # https://github.com/devernay/cminpack/issues/12
- sed -i "s|target_link_libraries(cminpack PUBLIC|target_link_libraries(cminpack PUBLIC cblas|g" CMakeLists.txt
+ curl -L https://github.com/devernay/cminpack/pull/50.patch | patch -p1
+}
- for _arch in ${_architectures}; do
- mkdir -p build-${_arch}-static && pushd build-${_arch}-static
- ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMINPACK_LIB_INSTALL_DIR=lib \
- -DBUILD_EXAMPLES=OFF -DBUILD_SHARED_LIBS=OFF ..
- make
- popd
- mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMINPACK_LIB_INSTALL_DIR=lib \
- -DBUILD_EXAMPLES=OFF ..
- make
- popd
+build() {
+ cd $srcdir/cminpack-${pkgver}
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DCMINPACK_LIB_INSTALL_DIR=lib -DBUILD_EXAMPLES=OFF ..
+ make
+ popd
done
}
package() {
for _arch in ${_architectures}; do
- cd "$srcdir/cminpack-${pkgver}/build-${_arch}-static"
- make install DESTDIR="$pkgdir"
cd "$srcdir/cminpack-${pkgver}/build-${_arch}"
make install DESTDIR="$pkgdir"
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll