summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa01246bde5e..af56ba584032 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,35 @@
pkgname=mingw-w64-cminpack
-pkgver=1.3.4
+pkgver=1.3.6
pkgrel=1
pkgdesc="A C/C++ rewrite of the MINPACK software (mingw-w64)"
arch=('any')
url='http://devernay.free.fr/hacks/cminpack/cminpack.html'
license=('GPL' 'LGPL')
-depends=('mingw-w64-crt')
+depends=('mingw-w64-crt' 'mingw-w64-cblas')
makedepends=('mingw-w64-cmake')
options=('!buildflags' 'staticlibs' '!strip')
source=("http://devernay.free.fr/hacks/cminpack/cminpack-${pkgver}.tar.gz")
-md5sums=('5d95527644f3eb924fea9aff55e0ebfb')
+md5sums=('2c7f81105f94ea9268617a1748cc3506')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd $srcdir/cminpack-${pkgver}
- sed -i "s|RUNTIME DESTINATION \${CMINPACK_LIB_INSTALL_DIR}|RUNTIME DESTINATION bin|g" CMakeLists.txt
-}
-
build() {
cd $srcdir/cminpack-${pkgver}
+ # https://github.com/devernay/cminpack/issues/12
+ sed -i "s|target_link_libraries(cminpack PUBLIC|target_link_libraries(cminpack PUBLIC cblas|g" CMakeLists.txt
+
for _arch in ${_architectures}; do
- unset LDFLAGS
mkdir -p build-${_arch}-static && pushd build-${_arch}-static
${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
-DCMINPACK_LIB_INSTALL_DIR=lib \
- -DBUILD_EXAMPLES=OFF ..
+ -DBUILD_EXAMPLES=OFF -DBUILD_SHARED_LIBS=OFF ..
make
popd
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
-DCMINPACK_LIB_INSTALL_DIR=lib \
- -DSHARED_LIBS=ON -DBUILD_EXAMPLES=OFF ..
+ -DBUILD_EXAMPLES=OFF ..
make
popd
done