summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed64b6a81f4e..b917f1acbb7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-expat
-pkgver=2.2.10
+pkgver=2.4.1
pkgrel=1
pkgdesc="An XML parser library (mingw-w64)"
arch=(any)
@@ -9,7 +9,7 @@ makedepends=(mingw-w64-configure)
depends=(mingw-w64-crt)
options=(!strip !buildflags staticlibs)
source=("http://downloads.sourceforge.net/expat/expat-${pkgver}.tar.bz2")
-sha256sums=('b2c160f1b60e92da69de8e12333096aeb0c3bf692d41c60794de278af72135a5')
+sha256sums=('2f9b6a580b94577b150a7d5617ad4643a4301a6616ff459307df3e225bcfbf40')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -17,7 +17,7 @@ build() {
cd "${srcdir}/expat-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure --without-docbook ..
+ ${_arch}-configure --without-docbook --without-examples --without-tests --without-xmlwf ..
make
popd
done
@@ -27,7 +27,6 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/expat-${pkgver}/build-${_arch}"
make DESTDIR="$pkgdir" install
- rm "$pkgdir"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
rm -r "$pkgdir/usr/${_arch}/share"