summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bf6a478de44..6152aacf5b3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ url='http://www.netlib.org/f2c/index.html'
license=('custom')
arch=('any')
depends=('mingw-w64-crt')
-makedepends=('mingw-w64-gcc' 'mingw-w64-environment')
+makedepends=('mingw-w64-gcc' 'mingw-w64-make')
options=('!buildflags' '!strip' 'staticlibs')
source=("http://www.netlib.org/f2c/libf2c.zip" libf2c-1.patch)
noextract=("libf2c.zip")
@@ -32,8 +32,7 @@ build() {
cd "${srcdir}"
for _arch in ${_architectures}; do
cp -r libf2c build-${_arch} && pushd build-${_arch}
- source mingw-env ${_arch}
- make -f makefile.u CFLAGS="${CFLAGS} -DUSE_CLOCK"
+ CFLAGS="-DUSE_CLOCK" ${_arch}-make -f makefile.u
popd
done
}