summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bd5887e1eca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=mingw-w64-fluidsynth-bin
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications (mingw-w64)"
+arch=('any')
+url="http://www.fluidsynth.org/"
+license=("GPL")
+depends=('mingw-w64-glib2'
+ 'mingw-w64-libsndfile'
+ 'mingw-w64-portaudio'
+ 'mingw-w64-readline')
+options=('strip' 'staticlibs')
+provides=('mingw-w64-fluidsynth')
+source=("http://repo.msys2.org/mingw/x86_64/mingw-w64-x86_64-fluidsynth-2.1.2-1-any.pkg.tar.xz")
+sha256sums=('SKIP')
+
+_architectures="x86_64-w64-mingw32"
+
+package() {
+ cd "${srcdir}/mingw64"
+ for _arch in ${_architectures}; do
+ mkdir -p ./* $pkgdir/usr/${_arch}/
+ cp -r ./* $pkgdir/usr/${_arch}/
+ done
+}