summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4e043526faf..c932194301b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-gst-plugins-bad
pkgver=1.14.2
-pkgrel=1
+pkgrel=2
pkgdesc="GStreamer Multimedia Framework Bad Plugins (mingw-w64)"
arch=(any)
url="http://gstreamer.freedesktop.org/"
@@ -10,11 +10,19 @@ depends=('mingw-w64-gstreamer' 'mingw-w64-orc')
makedepends=('mingw-w64-configure' 'mingw-w64-openh264' 'mingw-w64-nettle' 'mingw-w64-opus' 'mingw-w64-bzip2' 'mingw-w64-libsrtp' 'mingw-w64-vo-aacenc' 'mingw-w64-libkate' 'mingw-w64-librsvg' 'mingw-w64-openjpeg2' 'mingw-w64-opencv' 'mingw-w64-libfdk-aac' 'mingw-w64-librtmp0' 'mingw-w64-libwebp')
options=('!strip' '!buildflags' 'staticlibs')
-source=(${url}/src/gst-plugins-bad/gst-plugins-bad-${pkgver}.tar.xz)
-sha256sums=('34fab7da70994465a64468330b2168a4a0ed90a7de7e4c499b6d127c6c1b1eaf')
+source=(${url}/src/gst-plugins-bad/gst-plugins-bad-${pkgver}.tar.xz
+ 'c247745faaf885fd3fa094198fc0ea288e295dbf.patch')
+sha256sums=('34fab7da70994465a64468330b2168a4a0ed90a7de7e4c499b6d127c6c1b1eaf'
+ '65f6de70e7f08cd60fa913270f44c99baabd51b64bae3669c62d2b5cde1142eb')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/gst-plugins-bad-${pkgver}"
+
+ patch -Np1 < ../c247745faaf885fd3fa094198fc0ea288e295dbf.patch
+}
+
build() {
cd "${srcdir}/gst-plugins-bad-${pkgver}"